How to configure and adapt Aimeos based shops as developer
Forum rules: Always add your Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#4916 by cypriotxx
09 Nov 2017, 21:09
I have SSH access to shared hosting and this error comes up , they dont allow allow_url_fopen being on so is there any way passing this , i had a look online and i can see some using CURL instead of allow_url_fopen in other applications and it works , any help appreciated

public_html]$ composer create-project --prefer-dist laravel/laravel myshop


[Composer\Downloader\TransportException]
The "https://packagist.org/packages.json" file could not be downloaded: all
ow_url_fopen must be enabled in php.ini (https:// wrapper is disabled in th
e server configuration by allow_url_fopen=0
failed to open stream: no suitable wrapper could be found)
#4919 by aimeos
09 Nov 2017, 22:07
If composer doesn't support curl instead, you won't be able to install Aimeos directly on that server. Instead, install Aimeos in your local environment and sync the complete directory including all files and subdirectories to the shared web server.