Omnipay error

How to configure and adapt Aimeos based shops as developer
Forum rules
Always add your Aimeos and PHP version as well as your environment (Linux/Mac/Win)
kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

Omnipay error

Post by kshtjsharam68 » 28 Jan 2016, 11:16

I am using aimeos/payment and adding a new payment method using shopadmin of package but when using in frontent it is giving error FatalErrorException in OmniPay.php line 25:
Class 'Aimeos\MShop\Service\Provider\Payment\Base' not found
and this base file is not present in aimeo 2015 package but is in 2016 version. I need base.php and Iface.php in aimeo 1.0 version to use so how can i resolve this error and files problem.

User avatar
aimeos
Administrator
Posts: 3114
Joined: 01 Jan 1970, 00:00

Re: MSHOP error

Post by aimeos » 28 Jan 2016, 11:24

You need the corresponding extension to the Aimeos core you are using:
- Version: 2016.01 -> Core 2016.01 -> Extensions: 2016.01
- Version: 1.x -> Core 2015.10 -> Extensions: 2015.10

In your case for Laravel/Symfony version 1.x you need the 2015.10 version of the ai-payments extension.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

changing extension

Post by kshtjsharam68 » 28 Jan 2016, 11:33

How can i change my ai-payment extension to your specified version.

User avatar
aimeos
Administrator
Posts: 3114
Joined: 01 Jan 1970, 00:00

Re: MSHOP error

Post by aimeos » 28 Jan 2016, 11:38

Extensions are installed via composer. You need to add the "ai-payments" extension to the "require" section in your "composer.json" file:

Code: Select all

"require": {
  ...,
  "ai-payments": "2015.10"
},
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

update error

Post by kshtjsharam68 » 28 Jan 2016, 11:49

Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package ai-payments could not be found in any version, there may be a typo in the package name.

User avatar
aimeos
Administrator
Posts: 3114
Joined: 01 Jan 1970, 00:00

Re: MSHOP error

Post by aimeos » 28 Jan 2016, 11:54

Sorry, my fault! It must be

Code: Select all

"require": {
  ...,
  "aimeos/ai-payments": "~2015.10"
},
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

Error

Post by kshtjsharam68 » 28 Jan 2016, 11:59

[Composer\DependencyResolver\SolverProblemsException]
Problem 1
- The requested package aimeos/ai-payments dev-master could not be foun
d.
Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to you
r minimum-stability setting
see <https://groups.google.com/d/topic/compo ... c/discussi
on> for more details.
Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further
common problems.

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

Re: MSHOP error

Post by kshtjsharam68 » 28 Jan 2016, 12:03

srry , that was my mistake ..
i gave package in require-dev

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

Re: MSHOP error

Post by kshtjsharam68 » 28 Jan 2016, 12:14

Thank you that worked.

kshtjsharam68
Posts: 12
Joined: 27 Jan 2016, 18:37

Another error

Post by kshtjsharam68 » 28 Jan 2016, 12:34

Class '\Omnipay\\Gateway' not found
while using custom pay method.
how can resolve this

Post Reply