Help for integrating the Laravel package
Forum rules: Always add your Laravel, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#4401 by bill
14 Jul 2017, 00:18
HI

I am getting this error:
Code: Select all(1/1) InvalidArgumentException
Route [] not defined.


when I tried to do composer update :

here is my composer.json

Code: Select all"require": {
        "php": ">=5.6.4",
        "aimeos/aimeos-laravel": "dev-master",
       "aimeos/ai-payments": "dev-master"
#4402 by aimeos
14 Jul 2017, 11:29
For which URL do you get that error?
I guess, in your templates there's the URL for the JSON REST API generated now but either the route definition or the configuration for the route is missing somewhere.

The routes are there: https://github.com/aimeos/aimeos-laravel/blob/master/src/routes.php#L108
Route configuration is here: https://github.com/aimeos/aimeos-laravel/blob/master/src/default.php#L216
#4403 by bill
14 Jul 2017, 11:49
I am getting that error for all urls

Also I update my composer with "dev-master" and that is when the error occurs I wanted to fix the issue with the payment gateways

Any idea how to fix it ? Are you telling me to check the routes.php file ?
#4404 by aimeos
15 Jul 2017, 16:21
If you don't need a particular feature from the dev-master branch, you should use the current "~2017.07" version instead. But that shouldn't cause the problem you are describing.

We've done a installation of 2017.04 and then upgraded to dev-master for testing. That worked without problems so it must be something what you've changed in your project.

Can you please make sure that your your ./config/shop.php and the templates in ./resources/views/vendor/aimeos/shop/ is up to date? You can overwrite your current files with:
Code: Select allphp artisan vendor:publish --force


Did you copied and changed some of the Aimeos templates? If yes, you should temporarily remove them and check if it works again.