Help for integrating the Laravel package
Forum rules: Always add your Laravel, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#5478 by HimanshuBhandari
21 Jan 2018, 07:41
I am installed aimeos laravel package ~2017.10 on laravel 5.5 and PHP 7.0 on windows 10, installation successful with demo shop. Now I am trying to enable x currency in locale and each time I submit the form it says "The page has expired due to inactivity. Please refresh and try again." and I am unable to save it.
Is any configuration I missed? I found that it is regarding CSRF but I am not calling API yet.
I found that it is randomly occurred with "419 unknown status" error. I am sure that it is SCRF issue after searching this error,but not finding solution yet.
Last edited by HimanshuBhandari on 22 Jan 2018, 16:15, edited 1 time in total.
#5489 by aimeos
21 Jan 2018, 20:06
There seems to be something completly wrong with your environment. Do you have similar problems of a base Laravel 5.5 installation without Aimeos?
#5500 by HimanshuBhandari
22 Jan 2018, 16:14
Code: Select alldid you try to disable temporary CSRF at laravel?

Yes, In my VerifyCsrfToken.php file after disabling this way
Code: Select allprotected $except = [ '*', ];
able to enable currency.

aimeos wrote:There seems to be something completly wrong with your environment. Do you have similar problems of a base Laravel 5.5 installation without Aimeos?

I am able to run 3 other projects with Laravel without any such problem so I think environment should be good. No such problem without Aimeos.
#5505 by aimeos
22 Jan 2018, 21:36
Can you please throw away your current installation and install the Aimeos distribution (https://github.com/aimeos/aimeos#requirements)? It's the same as Laravel 5.5 and Aimeos 2017.10 but only ask some questions and configures the installation automatically. Then test that installation and see if the same errors occur.
#5511 by HimanshuBhandari
23 Jan 2018, 18:34
I have installed Aimeos with the given link and now I am in more trouble. :D
Now I got Site Add button, when I filled required data and save it, nothing happens.. I clicked again and again nothing, no error and no success message. Finally I clicked again on Local>Sites and what?? I am on Login page.. I logged in and able to see the added site.
I tried again to add a new Site this time on click of save my page expired again, even worse I found this error in console
Code: Select alljquery.min.js:4 OPTIONS http://127.0.0.1:8000/admin/default/jsonadm 401 (Unauthorized)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
(anonymous) @ js?lang=en:4352

I understand that this error means I am not logged in as Admin, but believe me I was logged in(checked multiple times).

In short, some times I gets logged out automatically, get page expired error and above console error, all at random, without any clue.
#5517 by aimeos
23 Jan 2018, 23:10
Dumb question: Did you ever try another browser? Do you have any anti virus software that performs checking pages on load?

Aimeos using standard Laravel authentication and session handling with CSRF tokens and you are the first who has massive problems in that area. Can you ask in the Laravel forums if there are any known problems with that and your environment?
#5523 by HimanshuBhandari
24 Jan 2018, 16:51
aimeos wrote:Dumb question:

No Question can be dumb :)

aimeos wrote:Did you ever try another browser?

Not till you asked. Well I tried same steps in Firefox Quantum and then on Edge, and first time EVER, something worked on Microsoft Edge (IE) and not on other browsers(Chrome and Firefox). Firefox is letting me Add site but not redirecting to Sites listing(may be there is no redirection), but if I again navigate to Local>Sites>Add, I got redirected to login page.
How it worked on Edge still a Question.

aimeos wrote:Do you have any anti virus software that performs checking pages on load?

Windows Defender is installed, but I don't expect any intervention from it.

aimeos wrote:Can you ask in the Laravel forums if there are any known problems with that and your environment?

Without any specifics it is difficult. Still I will try to solve before ask.

antonlinderer wrote:Maybe this has a lower value for your set up....

I have checked it and it is same. Moreover I am performing all the actions in one go, so..
#5528 by aimeos
24 Jan 2018, 21:59
Can you please post your ./app/Providers/AuthServiceProvider.php file?
Also can you post the HTTP request and response which fails with HTTP error 419?