Help for integrating the Laravel package
Forum rules: Always add your Laravel, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#3765 by thomasroelens
27 Dec 2016, 03:21
I tried to install the dev-master but composer doesn't download the required packages, see the message below
I do not have this problem when installing the 2016.10 version but then I get a MySQL error 1071 that the specified key was too long when I do the aimeos:setup, I read this should be fixed in the dev-master version.

Not sure if this is on my end since I never have had this problem with composer.
My composer is up to date and I'm using laravel 5.1

Code: Select allLoading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for aimeos/aimeos-laravel dev-master -> satisfiable by aimeos/aimeos-laravel[dev-master].
    - aimeos/aimeos-laravel dev-master requires aimeos/aimeos-core dev-master -> satisfiable by aimeos/aimeos-core[dev-master] but these conflict with your requirements or minimum-stability.
#3767 by aimeos
27 Dec 2016, 11:03
If you want to use dev-master, you need to add
Code: Select all    "prefer-stable": true,
    "minimum-stability": "dev",

in your composer.json. Otherwise, composer refuses to use development versions.