Symfony 4

Questions around the Aimeos bundle for the Symfony framework
Forum rules
Always add your Symfony, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
DamienWolfer

Symfony 4

Post by DamienWolfer » 14 Oct 2019, 14:39

Hi everyone,

I'm running a Symfony 4.3.5 App on PHP 7.3.7.
I'm trying to install Aimeos 2019.10 on this app.

Why does Aimeos still use FosUserBundle as this bundle is deprecated in Symfony 4?

Thanks for replies

Damien

User avatar
aimeos
Administrator
Posts: 3959
Joined: 01 Jan 1970, 00:00

Re: Symfony 4

Post by aimeos » 14 Oct 2019, 15:07

What is the suggested alternative now?
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

JinicMédia
Posts: 1
Joined: 08 Apr 2020, 13:32

Re: Symfony 4

Post by JinicMédia » 08 Apr 2020, 13:35

Hi, same questions here, FOSUserBundle is not avaible in Symfony 5. Now the standard way is to build youre own User with symfony basic stuff.

User avatar
aimeos
Administrator
Posts: 3959
Joined: 01 Jan 1970, 00:00

Re: Symfony 4

Post by aimeos » 08 Apr 2020, 16:59

We don't want to reinvent such basic stuff that should be available by default (incl. forgot password, etc.) so we are currently looking if the Sylius user bundle is a viable alternative we can use.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply