Missing locale in login page

How to configure and adapt Aimeos based shops as developer
Forum rules
Always add your Aimeos and PHP version as well as your environment (Linux/Mac/Win)
lukyiys
Posts: 1
Joined: 13 Sep 2020, 08:02

Missing locale in login page

Post by lukyiys » 13 Sep 2020, 08:12

Hello,

I configured routes in shop.php for using locale in url, everything works fine except login page.

When I hit /login, then login page is loaded, but when I use /en/login then page is not found(error 404). Probably url do not keep locale for login page.

/en/shop works fine.

Do I need some another configuration?

My routes configuration in shop.php

Code: Select all

	'routes' => [
		 'admin' => ['prefix' => 'admin', 'middleware' => ['web']],
		 'jqadm' => ['prefix' => 'admin/{site}/jqadm', 'middleware' => ['web', 'auth']],
		 'jsonadm' => ['prefix' => 'admin/{site}/jsonadm', 'middleware' => ['web', 'auth']],
		 'jsonapi' => ['prefix' => 'jsonapi', 'middleware' => ['web', 'api']],
		 'account' => ['prefix' => '{locale}/myaccount', 'middleware' => ['web', 'auth']],
		 'default' => ['prefix' => '{locale}/shop', 'middleware' => ['web']],
		 'update' => [],
	],

User avatar
aimeos
Administrator
Posts: 4248
Joined: 01 Jan 1970, 00:00

Re: Missing locale in login page

Post by aimeos » 13 Sep 2020, 10:23

There's a nice post how to configure the auth routes with locales:
https://laraveldaily.com/multi-language ... with-auth/
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply