Configure Stripe

Questions around the Aimeos bundle for the Symfony framework
Forum rules
Always add your Symfony, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
samking
Posts: 4
Joined: 15 Apr 2019, 08:40

Configure Stripe

Post by samking » 07 May 2019, 13:42

Hello,
I actually try to set up the Stripe payment.
I added 'composer.phar require league/omnipay omnipay/stripe ' and made a composer update, then I configured the Stripe payment with my API Public key and secret key but when I want to checkout my basket I have this message :
Class "\Aimeos\MShop\Service\Provider\Payment\Stripe" not available
I checked my Class and didn't see anything wrong how could I solve this please?
thank you.

User avatar
aimeos
Administrator
Posts: 3207
Joined: 01 Jan 1970, 00:00

Re: Configure Stripe

Post by aimeos » 07 May 2019, 15:48

You need the "aimeoscom/ai-payments" composer package for the integration of the Omnipay library too.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

samking
Posts: 4
Joined: 15 Apr 2019, 08:40

Re: Configure Stripe

Post by samking » 09 May 2019, 12:57

Thank you for your help.
But I have already install the ai-payments. My config works well with Paypal, so I installed "omnipay/stripe" and load my 2 API's keys but I syill have this error.

User avatar
aimeos
Administrator
Posts: 3207
Joined: 01 Jan 1970, 00:00

Re: Configure Stripe

Post by aimeos » 10 May 2019, 08:25

Which Aimeos version do you use?
Is this file available? ./ext/ai-payments/lib/custom/src/MShop/Service/Provider/Payment/Stripe.php
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

samking
Posts: 4
Joined: 15 Apr 2019, 08:40

Re: Configure Stripe

Post by samking » 20 May 2019, 17:49

Hi,
thank you for your reply.
I just made test and yes I have the stripe class into the folder.
After a composer update I success to access the stripe payment but there is still something that doesn't work...
I follow what write in the doc and set my settings like that : https://pasteboard.co/IfBwV0O.png
When I want to send Information to stripe I have an error 402 :

Code: Select all

shared-c7ae529e76a3c031c886c5f22b48ff24.js:1 POST https://api.stripe.com/v1/tokens 402
I've made test with Postman and my public and private keys are good all of them.
I made test to change the settings of stripe too but if I don't write stripe before my keys I have an error in my console that says that my API Key is empty.
Thank you for your help

Post Reply