Problems with loading images on frontend

Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules
Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
User avatar
aimeos
Administrator
Posts: 3522
Joined: 01 Jan 1970, 00:00

Re: Problems with loading images on frontend

Post by aimeos » 10 Oct 2019, 10:17

Is there any JS error before? Can you post all errors from the browser console?
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

einmaku
Posts: 11
Joined: 26 Sep 2019, 13:29

Re: Problems with loading images on frontend

Post by einmaku » 16 Oct 2019, 14:42

HI
We are still blocked for 2 weeks now and fighting with this problem. We cannot see any reason why this doen't work how it should.
I send you some more information of my expert:

Same page, but different behavior for images loaded in visible screen portion and that are loaded in the non-visible screen.
The error is in the core of aimeos. I feel that one of aimeos script is removing the src for the non-visible images, but unable to set it when it becomes visible

pls see the two attachments.
thanks
Attachments
src_code.png
src_code.png (203.75 KiB) Viewed 56 times
no_src_code.png
no_src_code.png (82.96 KiB) Viewed 56 times

einmaku
Posts: 11
Joined: 26 Sep 2019, 13:29

Re: Problems with loading images on frontend

Post by einmaku » 17 Oct 2019, 06:29

Hope you can solve the problem today............

User avatar
aimeos
Administrator
Posts: 3522
Joined: 01 Jan 1970, 00:00

Re: Problems with loading images on frontend

Post by aimeos » 17 Oct 2019, 07:44

Please remove the loading="lazy" in your templates. This causes problems in Chrome and has been removed from all templates in 19.7.3 I think. Templates you've already copied and modified can still contain the attribute you have to remove.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply