Search found 136 matches

by boettner
24 Jul 2023, 13:43
Forum: TYPO3 extension
Topic: JsonAPI bulk order autosuggest request leads to 404
Replies: 4
Views: 29403

Re: JsonAPI bulk order autosuggest request leads to 404

Simple solution for all cases in which it does not impose any security risks is setting $GLOBALS['TYPO3_CONF_VARS']['FE']['pageNotFoundOnCHashError'] to false. For other cases one has to deal with TYPO3 routing and define some kind of exclusion or special treatment for the ai[filter] maybe via a PSR...
by boettner
23 Jul 2023, 09:47
Forum: TYPO3 extension
Topic: JsonAPI bulk order autosuggest request leads to 404
Replies: 4
Views: 29403

Re: JsonAPI bulk order autosuggest request leads to 404

A follow up to my quick reply from Friday. I guess it‘s more like TYPO3 classifying it as not routable then. My first guess for a reason would be the nested GET array. I will try to debug that further to find the root cause. Changing the nested filter array to a single query string might be a soluti...
by boettner
21 Jul 2023, 13:15
Forum: TYPO3 extension
Topic: JsonAPI bulk order autosuggest request leads to 404
Replies: 4
Views: 29403

Re: JsonAPI bulk order autosuggest request leads to 404

At least in my setup the OPTIONS request returns an absolute URL scheme: "resources": {"attribute":"https:\/\/dev.domain.com\/jsonapi?ai%5Baction%5D=options&ai%5Bcontroller%5D=Jsonapi&ai%5Bresource%5D=attribute", "basket":"https:\/\/dev.domain.com...
by boettner
20 Jul 2023, 14:05
Forum: TYPO3 extension
Topic: JsonAPI bulk order autosuggest request leads to 404
Replies: 4
Views: 29403

JsonAPI bulk order autosuggest request leads to 404

Hi all, on TYPO 11.5.29 and Aimeos 22.10.7 the following GET request leads to a 404 when trying to add a product via the bulk order form https://dev.domain.com/jsonapi?ai[action]=options&ai[controller]=Jsonapi&ai[resource]=product&ai[filter][||][0][=~][product.code]=99000009580&ai[fi...
by boettner
17 Nov 2022, 06:31
Forum: TYPO3 extension
Topic: Upgrade from 18.10.11 to 22.7.1
Replies: 113
Views: 47747

Re: Upgrade from 18.10.11 to 22.7.1

Thanks once again I didn´t recognize the obvious... :roll:
by boettner
16 Nov 2022, 15:55
Forum: TYPO3 extension
Topic: Upgrade from 18.10.11 to 22.7.1
Replies: 113
Views: 47747

Re: Upgrade from 18.10.11 to 22.7.1

With aimeos_22.10.3-pre2 I still get the error we discussed by PM which is similar to this one from Moritz: I upgrade on the clients test machine and get another error in the upgrade wizard. sql_error.png My error: (1/1) Aimeos\Base\DB\Exception SQLSTATE[42S22]: Column not found: 1054 Unknown column...
by boettner
02 Nov 2022, 07:07
Forum: TYPO3 extension
Topic: Upgrade from 18.10.11 to 22.7.1
Replies: 113
Views: 47747

Re: Upgrade from 18.10.11 to 22.7.1

aimeos wrote: 27 Oct 2022, 11:40 The problem is related to the central factory featured in 2022.07 which assumes that you've also overwritten the sub-managers, which isn't true in your case. You can circumvent the error by adding a configuration for the sub-manager names:
That did it, many thanks!
by boettner
26 Oct 2022, 05:57
Forum: TYPO3 extension
Topic: Upgrade from 18.10.11 to 22.7.1
Replies: 113
Views: 47747

Re: Upgrade from 18.10.11 to 22.7.1

Hi everybody, I am in the same process of upgrading a TYPO3 11.5.17 Aimeos instance currently from 20.10.11 to 22.10.1-pre2. I extended the product model and manager following the docs https://aimeos.org/docs/latest/models/extend-managers/#custom-way I added two new fields to the product item which ...
by boettner
09 Feb 2022, 11:47
Forum: TYPO3 extension
Topic: Decorator for Checkout Confirm
Replies: 8
Views: 5331

Re: Decorator for Checkout Confirm

Try accesing the variable with $this->get('mytest');

And check if you are in a partial and have to pass the variable from the parent template.
by boettner
09 Feb 2022, 10:43
Forum: TYPO3 extension
Topic: Decorator for Checkout Confirm
Replies: 8
Views: 5331

Re: Decorator for Checkout Confirm

Hm, did you do a composer dumpautoload before clearing caches? Or the similar from the Install Tool if you are on TER. You could provoke a syntax error like removing a semicolon from a line to check if the class actually gets loaded. If that dosen´t help a look into your class and directory structur...