Questions around the Aimeos bundle for the Symfony framework
Forum rules: Always add your Symfony, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#5943 by Kay
03 Apr 2018, 18:19
Hi there,

I stumbled upon Aimeos today and decided to do a test installation on my local machine.
macOS 10.13.3 using Xampp 7.2.3.0 which includes Apache 2.4.29, MariaDB 10.1.31, PHP 7.1.7 and more. I have Composer version 1.6.3 installed globally. I followed these steps https://github.com/aimeos/aimeos-symfony to freshly install Aimeos.


Now I have some questions and problems, but I don't want to give up on Aimeos since it could be a nice tool to work with.

  1. In the installation directory bin/console --version gives the output Symfony 3.4.7 (kernel: app, env: dev, debug: true). Why isn't Symfony 4 in use and can I upgrade this installation to Symfony 4?
  2. On the webshop Frontend there is nothing left from the shoping chart, no currency, no language, no login, etc. Imageclick for a larger version, problem is marked with a purple square
    How can I fix this? The admin Front end works without such issues.
  3. The Symfony Profiler gives me 2 deprecation warnings:
    Code: Select all   Not setting "logout_on_user_change" to true on firewall "aimeos_admin" is deprecated as of 3.4, it will always be true in 4.0.
    Trace:
    {▼
     /Users/kay/repos/webshop/vendor/symfony/symfony/src/Symfony/Bundle/SecurityBundle/DependencyInjection/SecurityExtension.php:370 {▶}
      /Users/kay/repos/webshop/vendor/symfony/symfony/src/Symfony/Bundle/SecurityBundle/DependencyInjection/SecurityExtension.php:283 {▶}
    }
    Context:
    [▼
      "exception" => SilencedErrorContext {#993 ▶}
    ]


    Code: Select all   Not setting "logout_on_user_change" to true on firewall "aimeos_myaccount" is deprecated as of 3.4, it will always be true in 4.0.
    Trace:
    {▼
     /Users/kay/repos/webshop/vendor/symfony/symfony/src/Symfony/Bundle/SecurityBundle/DependencyInjection/SecurityExtension.php:370 {▶}
      /Users/kay/repos/webshop/vendor/symfony/symfony/src/Symfony/Bundle/SecurityBundle/DependencyInjection/SecurityExtension.php:283 {▶}
    }
    Context:
    [▼
      "exception" => SilencedErrorContext {#986 ▶}
    ]
    How can these best be fixed or should I reinstall? If so is there another guide to recommend to use for the reinstallation?

Thank you for reading and your answers. ;)
#5950 by aimeos
04 Apr 2018, 21:49
Hi Kay

Kay wrote:[*] In the installation directory bin/console --version gives the output Symfony 3.4.7 (kernel: app, env: dev, debug: true). Why isn't Symfony 4 in use and can I upgrade this installation to Symfony 4?


Symfony 4 is fully supported by Aimeos but the Symfony standard edition package still uses 3.4. You may have to install Symfony 4.0 manually and add Aimeos according to the documentation you followed.

Kay wrote:On the webshop Frontend there is nothing left from the shoping chart, no currency, no language, no login, etc. Imageclick for a larger version, problem is marked with a purple square
How can I fix this? The admin Front end works without such issues.


You can add the locale/currency selector as described by the article about this topic:
https://aimeos.org/docs/Symfony#Pages

For configuring the frontend login, you have to add the link for the FOS user bundle in the template.

Kay wrote:The Symfony Profiler gives me 2 deprecation warnings:
Code: Select all   Not setting "logout_on_user_change" to true on firewall "aimeos_admin" is deprecated as of 3.4, it will always be true in 4.0.



You can add the "logout_on_user_change: true" to your ./app/config/security.yml file to fix the warning:
Code: Select all    firewalls:
        aimeos_admin:
            logout_on_user_change: true
            ...
#6048 by EugeneR
18 Apr 2018, 10:07
Hi, you wrote:
aimeos wrote:Symfony 4 is fully supported by Aimeos but the Symfony standard edition package still uses 3.4. You may have to install Symfony 4.0 manually and add Aimeos according to the documentation you followed.


But all my tries was failed on `composer update` with this error:
Code: Select allYour requirements could not be resolved to an installable set of packages.

  Problem 1
    - aimeos/aimeos-symfony 2018.04.1 requires symfony/symfony ~2.8||~3.0||~4.0 -> satisfiable by symfony/symfony[3.1.x-dev, 3.2.x-dev, 3.3.x-dev, 3.4.x-dev, 4.0.x-dev, 4.1.x-dev, v3.1.0, v3.1.0-BETA1, v3.1.0-RC1, v3.1.1, v3.1.10, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.10, v3.2.11, v3.2.12, v3.2.13, v3.2.14, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6, v3.2.7, v3.2.8, v3.2.9, v3.3.0, v3.3.0-BETA1, v3.3.0-RC1, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.15, v3.3.16, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.2, v3.4.3, v3.4.4, v3.4.5, v3.4.6, v3.4.7, v3.4.8, v4.0.0, v4.0.0-BETA1, v4.0.0-BETA2, v4.0.0-BETA3, v4.0.0-BETA4, v4.0.0-RC1, v4.0.0-RC2, v4.0.1, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, 2.8.x-dev, 3.0.x-dev, v2.8.0, v2.8.0-BETA1, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.28, v2.8.29, v2.8.3, v2.8.30, v2.8.31, v2.8.32, v2.8.33, v2.8.34, v2.8.35, v2.8.36, v2.8.37, v2.8.38, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9, v3.0.0, v3.0.0-BETA1, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v3.0.6, v3.0.7, v3.0.8, v3.0.9].
    - aimeos/aimeos-symfony 2018.04.x-dev requires symfony/symfony ~2.8||~3.0||~4.0 -> satisfiable by symfony/symfony[3.1.x-dev, 3.2.x-dev, 3.3.x-dev, 3.4.x-dev, 4.0.x-dev, 4.1.x-dev, v3.1.0, v3.1.0-BETA1, v3.1.0-RC1, v3.1.1, v3.1.10, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.10, v3.2.11, v3.2.12, v3.2.13, v3.2.14, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6, v3.2.7, v3.2.8, v3.2.9, v3.3.0, v3.3.0-BETA1, v3.3.0-RC1, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.15, v3.3.16, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.2, v3.4.3, v3.4.4, v3.4.5, v3.4.6, v3.4.7, v3.4.8, v4.0.0, v4.0.0-BETA1, v4.0.0-BETA2, v4.0.0-BETA3, v4.0.0-BETA4, v4.0.0-RC1, v4.0.0-RC2, v4.0.1, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, 2.8.x-dev, 3.0.x-dev, v2.8.0, v2.8.0-BETA1, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.28, v2.8.29, v2.8.3, v2.8.30, v2.8.31, v2.8.32, v2.8.33, v2.8.34, v2.8.35, v2.8.36, v2.8.37, v2.8.38, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9, v3.0.0, v3.0.0-BETA1, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v3.0.6, v3.0.7, v3.0.8, v3.0.9].
    - symfony/symfony 2.8.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 3.0.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 3.1.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 3.2.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 3.3.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 3.4.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 4.0.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony 4.1.x-dev conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.10 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.11 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.12 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.13 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.14 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.15 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.16 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.17 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.18 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.19 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.20 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.21 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.22 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.23 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.24 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.25 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.26 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.27 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.28 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.29 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.30 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.31 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.32 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.33 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.34 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.35 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.36 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.37 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.38 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v2.8.9 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.0.9 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.0-RC1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.10 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.1.9 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.0-RC1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.0-RC2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.10 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.11 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.12 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.13 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.14 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.2.9 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.0-RC1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.10 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.11 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.12 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.13 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.14 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.15 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.16 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.3.9 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-BETA2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-BETA3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-BETA4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-RC1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.0-RC2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v3.4.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-BETA1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-BETA2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-BETA3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-BETA4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-RC1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.0-RC2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.1 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.2 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.3 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.4 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.5 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.6 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.7 conflicts with __root__[No version set (parsed as 1.0.0)].
    - symfony/symfony v4.0.8 conflicts with __root__[No version set (parsed as 1.0.0)].
    - Installation request for __root__ No version set (parsed as 1.0.0) -> satisfiable by __root__[No version set (parsed as 1.0.0)].
    - Installation request for aimeos/aimeos-symfony ~2018.04 -> satisfiable by aimeos/aimeos-symfony[2018.04.1, 2018.04.x-dev].

All similar, what I have found - https://stackoverflow.com/questions/480 ... -symfony-4

I have tried to delete `conflict` section in composer.json, and tried to use `symfony/skeleton` and `symfony/website-skeleton`. Nothing changes(
#6055 by EugeneR
19 Apr 2018, 10:13
aimeos wrote:Can you please post your composer.json file?


Yes, sure

Code: Select all{
    "prefer-stable": true,
    "minimum-stability": "dev",
    "type": "project",
    "license": "proprietary",
    "require": {
       "aimeos/aimeos-symfony": "~2018.04",
        "php": "^7.1.3",
        "ext-iconv": "*",
        "sensio/framework-extra-bundle": "^5.1",
        "symfony/asset": "^4.0",
        "symfony/console": "^4.0",
        "symfony/expression-language": "^4.0",
        "symfony/flex": "^1.0",
        "symfony/form": "^4.0",
        "symfony/framework-bundle": "^4.0",
        "symfony/lts": "^4@dev",
        "symfony/monolog-bundle": "^3.1",
        "symfony/orm-pack": "*",
        "symfony/process": "^4.0",
        "symfony/security-bundle": "^4.0",
        "symfony/serializer-pack": "*",
        "symfony/swiftmailer-bundle": "^3.1",
        "symfony/twig-bundle": "^4.0",
        "symfony/validator": "^4.0",
        "symfony/web-link": "^4.0",
        "symfony/webpack-encore-pack": "*",
        "symfony/yaml": "^4.0"
    },
    "require-dev": {
        "symfony/browser-kit": "^4.0",
        "symfony/css-selector": "^4.0",
        "symfony/debug-pack": "*",
        "symfony/dotenv": "^4.0",
        "symfony/maker-bundle": "^1.0",
        "symfony/phpunit-bridge": "^4.0",
        "symfony/profiler-pack": "*",
        "symfony/web-server-bundle": "^4.0"
    },
    "config": {
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php71": "*",
        "symfony/polyfill-php70": "*",
        "symfony/polyfill-php56": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install --symlink --relative %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
           "Aimeos\\ShopBundle\\Composer\\ScriptHandler::installBundle",
            "Aimeos\\ShopBundle\\Composer\\ScriptHandler::updateConfig",
            "Aimeos\\ShopBundle\\Composer\\ScriptHandler::setupDatabase",
            "@auto-scripts"
        ],
        "post-update-cmd": [
           "Aimeos\\ShopBundle\\Composer\\ScriptHandler::installBundle",
            "Aimeos\\ShopBundle\\Composer\\ScriptHandler::updateConfig",
            "Aimeos\\ShopBundle\\Composer\\ScriptHandler::setupDatabase",
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "id": "01CBENX1D19HRKCN1PC0H3RVBF",
            "allow-contrib": false
        }
    }
}
#6062 by aimeos
20 Apr 2018, 09:03
We haven't seen a conflict with "__root__" yet but this section in your composer.json looks fishy:
Code: Select all    "conflict": {
        "symfony/symfony": "*"
    },