Questions around the Aimeos bundle for the Symfony framework
Forum rules: Always add your Symfony, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#6268 by Seds
26 Jun 2018, 18:14
Hi,

I try since last week end to install Aimeos bundle but I meet each time a problem:

- last satursday, i couldn't add a category in a new shop. it said that there was no ID site but it was created et appeared in data base. I installed SF3.4 with AImeos 2018.04

- since this sunday, and today again, i can't login in /admin anymore:
when I enter my login & pwd on /admin it redirects on /admin_check with this message:
>> Unable to find the controller for path "/admin_check". The route is wrongly configured.

I tried to reinstall many times, several versions, with SF3.4/3.4.12/4.1(for this one Aimeos'doc isn't ok, MVC SF is totally changed), Aimeos 2018.04/2017.10 (on /list no css, I didn't tried /admin)

I don't know that's wrong

my today's config.. :
Symfony 3.4.12
AImeos 2018.07
PHP 7.0.23
WIN10

Please need help!

Seds
#6272 by aimeos
26 Jun 2018, 19:40
First of all, please make a new installation of Symfony 3.4.12 and Aimeos 2018.04 and follow exactly the documentation. Don't forget anything and don't add anything in https://github.com/aimeos/aimeos-symfony#installation

Especially the ./app/config/security.yml must be exactly the same as in the docs as an additional line or a removed line this file can immediately cause problems in your installation.

If you double checked that everything is OK, start the integrated PHP web server (php -S 127.0.0.1:8000 -t web) from you application directory and try to log into the admin interface (/admin) and open the list view (/list) with your browser console open. Do you get any errors in the "Network" tab?
#6292 by Seds
28 Jun 2018, 15:49
nice it's ok for the install, I add lines in security.yml instead of replace them.

one question again: when I add a site in locale/site, why aimeos says "Erreur No site ID available for creating a catalog item" in Categories ? Is it a bug, did I make a mistake or is there any configuration to do that I don't know?

thanks
#6301 by aimeos
29 Jun 2018, 12:30
To add a new site, you should use
Code: Select all./artisan aimeos:setup mysite

Adding a site in the locale site panel doesn't add the required type records to the database
#6302 by Seds
29 Jun 2018, 16:10
./artisan is for laravel, isn't it?
well I tried ./bin/console aimeos:setup mysite and it's ok now
thanks
#6303 by aimeos
29 Jun 2018, 19:04
Sorry and yes, it's
Code: Select all./bin/console aimeos:setup mysite

for Symfony :-)