Attributes Filter Shows All Attributes Even in a SubCategory

Questions around the TYPO3 integration and plugins
Forum rules
Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
superscotty19
Posts: 90
Joined: 13 May 2019, 08:09

Attributes Filter Shows All Attributes Even in a SubCategory

Post by superscotty19 » 30 Jun 2019, 01:14

Hi,

I'm not sure if this is my mis-configuration or there's a glitch, but I've added a catalog filter and an attributes filter to a page (I think I even just copied from the default install). Anyway, I have a page with 2 items, but the filter is going nuts - see screenshot.
Attachments
Screenshot_2019-06-29 Car Racks.png
Screenshot_2019-06-29 Car Racks.png (59.69 KiB) Viewed 560 times

User avatar
aimeos
Administrator
Posts: 3635
Joined: 01 Jan 1970, 00:00

Re: Attributes Filter Shows All Attributes Even in a SubCate

Post by aimeos » 30 Jun 2019, 10:22

What are the URL parameters for that view?
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star


User avatar
aimeos
Administrator
Posts: 3635
Joined: 01 Jan 1970, 00:00

Re: Attributes Filter Shows All Attributes Even in a SubCate

Post by aimeos » 01 Jul 2019, 04:50

Then I would say it's a misconfiguration because it seems you've set a default category and the faceted search isn't aware of that.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

superscotty19
Posts: 90
Joined: 13 May 2019, 08:09

Re: Attributes Filter Shows All Attributes Even in a SubCate

Post by superscotty19 » 02 Jul 2019, 03:46

Hey,

Ah OK. I did have both a catalog filter CE and a Catalog Attributes CE (to create separate "Categories" and "Filter" headings on the frontend ... or so I thought), and the catalog filter had the "Display categories beginning from the following node" set to Car Racks.

I have now hidden the Catalog Attributes CE and put everything into the Catalog Filter CE (keeping the Car Racks default category in the plugin tab/settings). Upon doing so, nothing changes - looks exactly the same as the screenshot previously sent. So, I set "Display categories ... " to nothing, annnnd now it's worse, showing the entire Catalog in the Categories filter.

Not sure what else is left to (mis) configure?
-S.

User avatar
aimeos
Administrator
Posts: 3635
Joined: 01 Jan 1970, 00:00

Re: Attributes Filter Shows All Attributes Even in a SubCate

Post by aimeos » 02 Jul 2019, 10:47

When you don't set a default category in the filter, category tree and attribute counts are in par because they count the same products. If you set a default category, your category tree will show only the subtree and the counts for the products in the subtree while the attribute counts still use all products. Same would apply to the supplier (brand) filter.

Reason behind: No one had the requirement yet to show an attribute filter for a category tree limited by a default start category and if your category contains only two products, the attribute filter doesn't make sense at all.

Might be worth adding that restriction to the attribute and supplier filter in the future nevertheless ...
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

superscotty19
Posts: 90
Joined: 13 May 2019, 08:09

Re: Attributes Filter Shows All Attributes Even in a SubCategory

Post by superscotty19 » 04 Jul 2019, 08:44

Hey,

Ok but I'm still getting the mess. What specifically do I need to do? I tried setting/unsetting the "Display categories beginning from the following node" setting but that did nothing.

Thanks,
-S.

User avatar
aimeos
Administrator
Posts: 3635
Joined: 01 Jan 1970, 00:00

Re: Attributes Filter Shows All Attributes Even in a SubCategory

Post by aimeos » 04 Jul 2019, 16:09

You have the category filter and the attribute filter on the list page. Now there are two options:
- Use the global list page with category and attribute filter (all not restricted to a default category) for all list views (also check that the category doesn't contain a "target" value in the Aimeos admin interface)
- If you want to use specific list pages for each category by adding the page ID as target in the category panel of the admin interface, remove the attribute filter
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

superscotty19
Posts: 90
Joined: 13 May 2019, 08:09

Re: Attributes Filter Shows All Attributes Even in a SubCategory

Post by superscotty19 » 17 Jul 2019, 22:47

Hi,

Yes, that's what I did (i.e. removed the attribute filter) ... but it still doesn't work! See attached ...

-S
Attachments
Screenshot_2019-07-17 Dutch Cycle Lightning [TYPO3 CMS 8 7 4].png
Screenshot_2019-07-17 Dutch Cycle Lightning [TYPO3 CMS 8 7 4].png (16.99 KiB) Viewed 450 times
Screenshot_2019-07-17 Dutch Cycle Lightning [TYPO3 CMS 8 7 4].png
Screenshot_2019-07-17 Dutch Cycle Lightning [TYPO3 CMS 8 7 4].png (41.31 KiB) Viewed 450 times

User avatar
aimeos
Administrator
Posts: 3635
Joined: 01 Jan 1970, 00:00

Re: Attributes Filter Shows All Attributes Even in a SubCategory

Post by aimeos » 18 Jul 2019, 17:15

The catalog filter component contains search, categories and attribute filter. You should use the catalog tree plugin instead if you only want to show the categories.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply