Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#4818 by Dennis
25 Oct 2017, 11:53
Hi,

after updating the aimeos extension from version 17.4.1-pre8 to 17.10.0, we get an error while executing the update script and in the aimeos backend module, too:

The following error occurs in the update script:

Class "\Aimeos\MShop\Common\Manager\Decorator\Sitecheck" not available
#0 /srv/httpd/.../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mshoplib/src/MShop/Common/Factory/Base.php(123): Aimeos\MShop\Common\Factory\Base::addDecorators(Object(Aimeos\MShop\Context\Item\Standard), Object(Aimeos\MShop\Locale\Manager\Standard), Array, '\\Aimeos\\MShop\\C...')
#1 /srv/httpd/.../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mshoplib/src/MShop/Locale/Manager/Factory.php(157): Aimeos\MShop\Common\Factory\Base::addManagerDecorators(Object(Aimeos\MShop\Context\Item\Standard), Object(Aimeos\MShop\Locale\Manager\Standard), 'locale')
#2 /srv/httpd/.../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mshoplib/setup/MShopAddLocaleLangCurData.php(54): Aimeos\MShop\Locale\Manager\Factory::createManager(Object(Aimeos\MShop\Context\Item\Standard), 'Standard')
#3 /srv/httpd.../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mwlib/src/MW/Setup/Manager/Multiple.php(204): Aimeos\MW\Setup\Task\MShopAddLocaleLangCurData->migrate()
#4 /srv/httpd/../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mwlib/src/MW/Setup/Manager/Multiple.php(198): Aimeos\MW\Setup\Manager\Multiple->migrateTasks(Array, Array)
#5 ...

The following error occurs when opening the aimeos backend module:

Uncaught TYPO3 Exception
Class "\Aimeos\MShop\Common\Manager\Decorator\Sitecheck" not available

Aimeos\MShop\Exception thrown in file
/srv/httpd/.../typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mshoplib/src/MShop/Common/Factory/Base.php in line 63.


I cleared all available caches (including autoload information).
Can you say what could be the reason for getting this error and how we can solve it? This would be very nice!
Thank you very lot in advance!!!


Aimeos web shop 17.10.0, TYPO3 8.7.7, PHP version 7.0.24-1~dotdeb+8.1
#4819 by Dennis
25 Oct 2017, 15:08
A temporary solution for today and just for testing purposes was to make the following setting in the aimeos extension configuration:

cache.useAPC = 0

[Use APC cache
cache.useAPC (boolesch)
(If Aimeos configuration values should be cached in the APC user cache)]