Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#1684 by vikram
17 Jul 2015, 06:50
Hi,

I get this error in Typo3 frontend after clicking the checkout button.

Code: Select allFatal error: Declaration of MShop_Service_Provider_Payment_OmniPay::updateSync() must be compatible with MShop_Service_Provider_Interface::updateSync($additional) in /var/www/html/typo3cms/typo3_710/typo3conf/ext/aimeos/Resources/Extensions/ai-payments/lib/custom/src/MShop/Service/Provider/Payment/OmniPay.php on line 22


Installed ai-payments with "omnipay/buckaroo": "~2.0"

Configured the Aimeos payment setting.

omnipay.type = Buckaroo
omnipay.testmode = 1

return array(
'websiteKey' => 'test',
'secretKey' => 'test',
'testMode' => true,
);

I am working on a local setup.

regards
Vikram Mandal
//FiveE.in
#1685 by aimeos
17 Jul 2015, 08:05
vikram wrote:
Code: Select allFatal error: Declaration of MShop_Service_Provider_Payment_OmniPay::updateSync() must be compatible with MShop_Service_Provider_Interface::updateSync($additional) in /var/www/html/typo3cms/typo3_710/typo3conf/ext/aimeos/Resources/Extensions/ai-payments/lib/custom/src/MShop/Service/Provider/Payment/OmniPay.php on line 22



I think you've installed the Aimeos TYPO3 2.2.x extension from TER, which uses these branches:
- TYPO3 extension: 2.2-LTS
- Aimeos core: 2015.03

To get the ai-payments extension working, you need the latest code from GitHub:
- TYPO3 extension: dev-master
- Aimeos core: dev-master
- ai-payments: dev-master

How to get them is explained here: https://aimeos.org/docs/TYPO3/Download_Aimeos#Latest_code
#1686 by vikram
18 Jul 2015, 07:17
Hi,

I need some help getting the latest code.

When I do :
git clone https://github.com/aimeos/aimeos-typo3.git aimeos

I do get the files but the version of this Typo3 extension is '2.2.0' ..TER has '2.2.3'
So if there is a "dev-master" branch version I am clueless how I can get it.

Also after adding the following to composer.aimeos.json

"aimeos/aimeos-core": "dev-master",
"aimeos/ai-zend2-i18n": "dev-master",
"aimeos/ai-typo3": "dev-master",
"aimeos/ai-payments": "dev-master"

I am asked for Git Token. After providing the token I get:

[Composer\Downloader\TransportException]
The "https://api.github.com/repos/aimeos/arcavias-core" file could not be d
ownloaded (HTTP/1.1 404 Not Found)

Please help me out.
Thank you

regards
Vikram
#1687 by aimeos
18 Jul 2015, 10:10
vikram wrote:git clone https://github.com/aimeos/aimeos-typo3.git aimeos

I do get the files but the version of this Typo3 extension is '2.2.0' ..TER has '2.2.3'
So if there is a "dev-master" branch version I am clueless how I can get it.


The minor versions are only updated in the stable branch, so you already have the latest version.

vikram wrote:Also after adding the following to composer.aimeos.json

"aimeos/aimeos-core": "dev-master",
"aimeos/ai-zend2-i18n": "dev-master",
"aimeos/ai-typo3": "dev-master",
"aimeos/ai-payments": "dev-master"

I am asked for Git Token. After providing the token I get:

[Composer\Downloader\TransportException]
The "https://api.github.com/repos/aimeos/arcavias-core" file could not be d
ownloaded (HTTP/1.1 404 Not Found)


Can you post your complete composer.aimeos.json file? I guess, there's a "repository" section in it that shouldn't be there any more. Did you copy the composer.aimeos.json from the TER version?
#1688 by vikram
20 Jul 2015, 07:59
Hi,

I used the latest code from Git and every things seem to go almost fine. I am not asked for any credentials now.

I also was being redirected to Buckaroo test url... but some weird things are happening. All files and dir under /typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/ some how gets deleted! I tried this in other setup and same thing is happening.

My composer.aimeos.json file

Code: Select all{
   "name": "aimeos/aimeos-typo3",
   "description": "Aimeos TYPO3 extension for web shops, portals and market places",
   "homepage": "https://www.aimeos.org",
   "license": "LGPL-3.0",
   "keywords": ["e-commerce", "shop", "portal", "market place"],
   "support": {
      "source": "https://github.com/aimeos/aimeos-typo3",
      "issues": "https://github.com/aimeos/aimeos-typo3/issues",
      "forum": "https://aimeos.org/help",
      "wiki": "https://aimeos.org/docs"
   },
   "minimum-stability": "dev",
   "prefer-stable": true,
   "require": {
      "php": ">=5.3.2",
      "aimeos/aimeos-core": "dev-master",
      "aimeos/ai-zend2-i18n": "dev-master",
      "aimeos/ai-typo3": "dev-master",
      "aimeos/ai-payments": "dev-master",
      "omnipay/buckaroo": "~2.0"
   },
   "require-dev": {
      "squizlabs/php_codesniffer": "1.*",
      "phpunit/phpunit": "3.7.*",
      "phing/phing": "2.4.*"
   },
   "config": {
      "vendor-dir": "Resources/Libraries"
   },
   "extra": {
      "installer-paths": {
         "Resources/Extensions/{$name}/": ["type:aimeos-extension"]
      }
   },
   "scripts": {
      "post-install-cmd": [
         "cp -r Resources/Libraries/aimeos/aimeos-core/client/html/themes/* Resources/Public/Themes/"
      ],
      "post-update-cmd": [
         "cp -r Resources/Libraries/aimeos/aimeos-core/client/html/themes/* Resources/Public/Themes/"
      ]
   }
}
#1689 by aimeos
20 Jul 2015, 08:32
vikram wrote:I also was being redirected to Buckaroo test url... but some weird things are happening. All files and dir under /typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/ some how gets deleted! I tried this in other setup and same thing is happening.


If you upgraded, "Resources/Libraries/aimeos/arcavias-core/" was deleted and replaced by "Resources/Libraries/aimeos/aimeos-core/"

The interesting part of Buckaroo is now if it works out of the box or if some special handling is required like for other payment gateways implemented in the ai-payments extension.

vikram wrote:My composer.aimeos.json file


The file is correct.
#1690 by vikram
20 Jul 2015, 09:16
ok.

I see
aimeos/Resources/Extensions/ai-payments/vendor/omnipay

Is now
aimeos/Resources/Libraries/omnipay

What I am worried is How did the "aimeos/Resources/Libraries/aimeos/aimeos-core/" dir contents get deleted by itself.

This was giving to Typo3 error.. file not found.
I ran the composure update again to get the files under aimeos/Resources/Libraries/aimeos/aimeos-core/
#1691 by aimeos
20 Jul 2015, 09:35
I've taken these steps:
1.) git clone https://github.com/aimeos/aimeos-typo3 aimeos
2.) Edit composer.aimeos.json and added:
Code: Select all                "aimeos/ai-payments": "dev-master",
                "omnipay/omnipay": "~2.0"

3.) Run "COMPOSER=composer.aimeos.json composer update --no-dev"

-> "aimeos/Resources/Libraries/aimeos/aimeos-core/" is available
-> "aimeos/Resources/Libraries/omnipay/..." is there
-> "aimeos/Resources/Extensions/ai-payments/" is at the correct place

Executing "phing deploy" creates a versioned zip file that you can install easily in any TYPO3 installation.
#1692 by vikram
21 Jul 2015, 05:06
Hi,

You need to believe me that the dir "aimeos/Resources/Libraries/aimeos/aimeos-core/" goes empty. This happened again last evening. I have now a new setup and got all the latest code. And hoping it would not happen again :|

Also the latest code has some JS / Url related error.. not able to update / remove items from basket.

Thank you
#1694 by aimeos
21 Jul 2015, 11:28
vikram wrote:You need to believe me that the dir "aimeos/Resources/Libraries/aimeos/aimeos-core/" goes empty. This happened again last evening. I have now a new setup and got all the latest code. And hoping it would not happen again :|


The big question is: Why is this happening? The directory won't disappear without any cause. The only thing I can think about is that there's some automatic update mechanism that installs the latest version from TER over your custom one because the the version numbers are 2.2.0 vs. 2.2.3 from TER.

vikram wrote:Also the latest code has some JS / Url related error.. not able to update / remove items from basket.


I think this might be a related problem because in my test installation (6.2) it works without problems. Which version of 7.x do you use? We got it only running flawlessly on 7.0 up to now. All other versions had one or another problem.