Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#2343 by crazyforester
18 Jan 2016, 11:07
Hello,
I tried to integrate aimeos_pay typo3 extension to my Aimeos web shop 2.4.3 but I suppose I miss something.
I installed the extension ai-payments in regular way as Typo3 extension (not composer ) and when I try to enter a new Payment , I see the following error
Class "MShop_Service_Provider_Payment_Omnipay" not available . If I put down "Widecard" - it is the same
I tried with Wirecard, because I want to use wirecard as payment gateway.
Could you tell what I do wrong
thanks
#2345 by aimeos
18 Jan 2016, 11:53
crazyforester wrote:I tried to integrate aimeos_pay typo3 extension to my Aimeos web shop 2.4.3 but I suppose I miss something.
I installed the extension ai-payments in regular way as Typo3 extension (not composer ) and when I try to enter a new Payment , I see the following error
Class "MShop_Service_Provider_Payment_Omnipay" not available .


Please do not install composer extensions manually in TYPO3!
You only need to install the aimeos and aimeos_pay extensions. Afterwards, the Omnipay drivers will be available automatically.
#2349 by crazyforester
18 Jan 2016, 13:55
Yes, that's right. I have installed them in regular way as Typo3 extensions.
I entered a new Payment "OmniPay" and I could not undestand what is the right Omnipay driver for omnipay.type=

I have as a result "Class '\Omnipay...." not found
I would like to initialize wirecard
I couldn't find an example
#2351 by aimeos
18 Jan 2016, 14:29
crazyforester wrote:Yes, that's right. I have installed them in regular way as Typo3 extensions.
I entered a new Payment "OmniPay" and I could not undestand what is the right Omnipay driver for omnipay.type=


Omnipay drivers are named according to their namespaces/classes, which is "Wirecard" in your case.

crazyforester wrote:I have as a result "Class '\Omnipay...." not found
I would like to initialize wirecard
I couldn't find an example


Omnipay gateways without an own implementation must be configured according to
https://aimeos.org/docs/User_Manual/Administration_Interface/Service_list#Omnipay

Here are the expected Wirecard parameters:
https://github.com/igaponov/omnipay-wirecard/blob/master/src/Gateway.php#L30
#2368 by crazyforester
25 Jan 2016, 08:14
Yes, drivers are according their namespace "Wirecard"
I have entered the expected Wirecard parameters:
https://github.com/igaponov/omnipay-wir ... ay.php#L30
'username' => 'D***',
'password' => 'j***,
'signature' => 'B8AKTP***',

and when I get to the final step , after I have select payment Wirecard in my case and have checked terms
then I see
Server error 500
and
....id=27&ai%5Bcontroller%5D=checkout&ai%5Baction%5D=index&ai%5Bc_step%5D=order. It may be down for maintenance or configured incorrectly.

I work fine with other payment method
#2369 by aimeos
25 Jan 2016, 09:55
crazyforester wrote:Server error 500
I work fine with other payment method


Looks like the Omnipay Wirecard driver causes a fatal error. Do you have more information about that in your logs?
#2381 by crazyforester
26 Jan 2016, 07:05
I think the problem is in omnipay
here is the error
Fatal error: Call to a member function serialize() on a non-object in /html/typo3/typo3conf/ext/aimeos_pay/Resources/Libraries/igaponov/omnipay-wirecard/src/Message/AbstractRequest.php on line 171
#2415 by Bollerx
28 Jan 2016, 10:27
The attachment wirecard.png is no longer available

I've also problems with adding wirecard payment driver. I've looked for parameters but every time i get error.
Can you give me an example of integration? why can't i save changes, every time i try i get the "attached image" error, even if i deleted the row from db. table?
Thanks.
Attachments
wirecard.png
wirecard.png (35.1 KiB) Viewed 1065 times
#2416 by aimeos
28 Jan 2016, 10:34
You already have a payment service entry with the code "Wirecard" in you database.
#2417 by Bollerx
28 Jan 2016, 10:50
Class "MShop_Service_Provider_Payment_Wirecard" not available
getting the same error, but it saves anyway, i deleted and created again, but the error stays.