BCC-Mail is not sent

Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules
Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
codefresser
Posts: 3
Joined: 22 Jan 2016, 17:59

BCC-Mail is not sent

Post by codefresser » 25 Jan 2016, 19:55

Hello people!

I'm having some trouble with receiving notification mails for the shop owner.
I configured the mail address in typoscript setup like this

Code: Select all

plugin.tx_aimeos.settings.client.html.email.bcc-email = mail@domain.com
I created a scheduler task (Aimeos Shop e-mail scheduler).
After placing a test-order, I run this task manually. Then the customer receives the order confirmation, but there's no bcc-mail sent to the shop owner.

I also tried the Extbase CommandController Task, 'cause I read about problems with the Aimeos tasks and TYPO3 CMS 6.2.x, but that ended with no mails being sent at all.

any hints on this? thx in advance.

PS: I'm working with TYPO3 CMS 6.2.15 and aimeos 2.4.1

User avatar
aimeos
Administrator
Posts: 3097
Joined: 01 Jan 1970, 00:00

Re: BCC-Mail is not sent

Post by aimeos » 25 Jan 2016, 22:19

codefresser wrote:

Code: Select all

plugin.tx_aimeos.settings.client.html.email.bcc-email = mail@domain.com
Did you've added it into the TypoScript field of the e-mail scheduler?
codefresser wrote: I also tried the Extbase CommandController Task, 'cause I read about problems with the Aimeos tasks and TYPO3 CMS 6.2.x, but that ended with no mails being sent at all.
Can you update to the latest version and try again?
codefresser wrote: PS: I'm working with TYPO3 CMS 6.2.15 and aimeos 2.4.1
I think there was a bug in the e-mail scheduler before 2.4.3 but only for TYPO3 7.4+
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

codefresser
Posts: 3
Joined: 22 Jan 2016, 17:59

Re: BCC-Mail is not sent

Post by codefresser » 26 Jan 2016, 07:10

aimeos wrote: Did you've added it into the TypoScript field of the e-mail scheduler?
No, I added it to my typoscript setup. Adding it to the TSconfig of the scheduler task fixed it. Thanks.
codefresser wrote: I also tried the Extbase CommandController Task, 'cause I read about problems with the Aimeos tasks and TYPO3 CMS 6.2.x
aimeos wrote: I think there was a bug in the e-mail scheduler before 2.4.3 but only for TYPO3 7.4+
The docs say:
Since Aimeos 2.3 in TYPO3 6.2, you have to use the Extbase CommandController Task for sending e-mails due to a bug in TYPO3 6.2. For TYPO3 7.x please continue to use the Aimeos e-mail task.
And here's where I found this: https://aimeos.org/docs/TYPO3/Install_A ... uler_tasks

Either way, for me the scheduler task works with 6.2.15 and 2.4.1

Thanks for your help and the quick response.

Post Reply