Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#2516 by goerch
19 Feb 2016, 20:17
I have a problem installing the new Version 16.1.2. On my local system the upgrade fails from 2.4.3, testing on a new typo3 - installation (not local) the installation 16.1.2 fails. The database update - script stopped with an error "failed: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (latin1_german1_ci,IMPLICIT) for operation '='" and following a list of items and scripts from #0 to #21
like #0 "/mnt/webf/d2/64/5287964/htdocs/xxx/typo3conf/ext/aimeos/Resources/Libraries/aimeos/aimeos-core/lib/mshoplib/src/MShop/Common/Manager/Base.php(914): Aimeos\MW\DB\Statement\PDO\Simple->execute()"

Testing system: T3 6.2.15, PHP 5.5.32, MySQL 5.5.45

What can i do? The idea was to upgrade from 2.4.3, because i need a tax feature (prices without tax) for a b2b shop.
#2517 by aimeos
20 Feb 2016, 00:30
Can you please check the collation of your fe_users and the static info tables? These are the only ones that Aimeos is joining in certain queries. I guess the collation is different from the Aimeos mshop/madmin tables (utf8_general_ci).
#2525 by goerch
22 Feb 2016, 10:58
Thank you, it seems to be the problem. Changing the collation to utf8_general_ci in the table "fe_user" AND the fields in "fe_user" solve the problem in one test installation. On local installation i can't see the backend. This could maybe a caching problem, the update script goes well, but the backend module shows only a blank page. I am looking for a solution and then i will report.
#2526 by aimeos
22 Feb 2016, 11:18
goerch wrote:On local installation i can't see the backend. This could maybe a caching problem, the update script goes well, but the backend module shows only a blank page. I am looking for a solution and then i will report.


Can you please have a look into the error log of your web server if there's something wrong?
You should also check in the web console of your browser if there's any Javascript error.
#2539 by goerch
24 Feb 2016, 11:04
So, the local installation: Installation is ok, but starting aimeos backend displays the following error: "Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in xxx\typo3conf\ext\aimeos\Resources\Libraries\zendframework\zend-servicemanager\src\ServiceManager.php on line 281"

Local system: T3 6.2.9, XAMPP on Windows, PHP 5.4.27, MySQL 5.5.36
#2541 by aimeos
24 Feb 2016, 13:58
Unfortunately, the used Zend component pushed the required PHP version up to 5.5. We already replaced Zend in the latest code base with a low resource implementation which only requires PHP 5.4. You can give it a try by downloading it from this URL:
https://aimeos.org/fileadmin/download/aimeos_16.2.0-b1.zip
#2542 by goerch
24 Feb 2016, 14:19
Thank you i will try it.

But the next error is installing Version 2.4.3: Update-Script breaks with
"Executing statement "CREATE INDEX "idx_t3feuad_refid" ON "fe_users_address" ("refid");
" failed: SQLSTATE[42000]: Syntax error or access violation: 1072 Key column 'refid' doesn't exist in table".

T3 6.2.9
#2543 by goerch
24 Feb 2016, 14:36
First report: Version 6.2.0 b works fine for me. No problems with installation. This solves also the problem with the update script.