Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#3938 by 27bit.ru
22 Feb 2017, 04:11
Hi.
My cms typo3 7.6.15, aimeos 16.10.3, bootstrap pack 6.2.16

I have the same problem. After purchase, the customer receives letters with the data to enter the personal cabinet, but when you try to use this data to log - writes input error.
I have the standard pages of the tree, after the shop installation.
What could be the problem?

Also after logging errors, there is no opportunity to go to another user (for example - user"test" password"test"). Until you delete the problem user.
Last edited by 27bit.ru on 27 Feb 2017, 11:11, edited 2 times in total.
#3939 by aimeos
22 Feb 2017, 09:20
Can you log in using the frontend login form with a user you've created in the TYPO3 backend?

Your PID is set using the wrong configuration. It must be:
Code: Select allplugin.tx_aimeos.settings.mshop.customer.manager.typo3.pid-default = 2
#3940 by 27bit.ru
22 Feb 2017, 09:36
aimeos wrote:Can you log in using the frontend login form with a user you've created in the TYPO3 backend?

Your PID is set using the wrong configuration. It must be:
Code: Select allplugin.tx_aimeos.settings.mshop.customer.manager.typo3.pid-default = 2


No. This does not solve the problem.
I understand that after a data entry errors fall into the cookie, but why do they hinder go immediately to another user. If you change the browser the user can test to login without problems. But the new user feels bad to come in any browser.
Try to buy goods on the test product - http://new.texnodom25.ru
But before you go under the name "test", and then under a new user.
Last edited by 27bit.ru on 22 Feb 2017, 09:47, edited 1 time in total.
#3942 by 27bit.ru
22 Feb 2017, 09:53
aimeos wrote:Can you log in with an user created in the TYPO3 backend?


Yes, I created a user "test2", password"test2" hands, can be accessed only in the new browser(mozilla). In the old browser(opera) clearing the cache does not work.

But the cookie is not such a serious problem, why the new buyer can not store their data on the go?
#3948 by 27bit.ru
22 Feb 2017, 16:49
aimeos wrote:Tried to log in with user "test2" and password "test2" at http://new.texnodom25.ru/lichnyi-kabinet/ but that doesn't work. Seems to be a TYPO3 issue to me at the moment.

If you need 1:1 support, the Aimeos company can help you: https://aimeos.com/support/


I had just entered the private office test2, without any problems. well, I will continue to look for the problem itself.
#3949 by aimeos
22 Feb 2017, 16:53
Ok, was now able to log in too.

This setting only works for newly created users:
Code: Select allplugin.tx_aimeos.settings.mshop.customer.manager.typo3.pid-default = 2

For existing users, you have to update the "pid" column to "2" in the fe_users table.