Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#2760 by thomas27
10 May 2016, 11:47
Hi,

I´m using Typo3 7.6.6, PHP 7.0.6, aimeos 16.4.2 and have installed the extensions saltedpasswords 7.6.0, rsaauth 7.6.0, femanager 2.3.0.
The automatic account creation is working and the user get's an email with their password and username. But the password is not working. The user must reset the password with the felogin extension.

I have tried to configure in my typo3 setup:
plugin.tx_aimeos.settings.mshop.customer.manager.password.name = Standard
plugin.tx_aimeos.settings.mshop.customer.manager.password.options= {
}
plugin.tx_aimeos.settings.mshop.customer.manager.salt = mshop

And I tried Hash, but the result is the same.

Do I need to configure anything else?
#2761 by aimeos
10 May 2016, 11:58
First of all: Which Aimeos version do you use?

thomas27 wrote:plugin.tx_aimeos.settings.mshop.customer.manager.password.name = Standard
plugin.tx_aimeos.settings.mshop.customer.manager.password.options= {
}
plugin.tx_aimeos.settings.mshop.customer.manager.salt = mshop


It shouldn't be necessary to change any settings. The defaults used in the TypoScript included in the page tree we offer are exactly tailored to the TYPO3 environment.
#2762 by thomas27
10 May 2016, 14:25
First of all: Which Aimeos version do you use?


aimeos 16.4.2

• Benutzerkonto xxx@xmx.at
• Passwort $1$GRKpZgHl$Bd4sOPj0Ai0jiIXztaGKl1

The password looks like the decypted password from the database but it isn´t the same.
#2763 by aimeos
10 May 2016, 18:54
You are right. We will fix this and release a new version within 1-2 days.
Thank you very much for the hint :-)
#2775 by aimeos
12 May 2016, 08:21
We've created a new version fixing the problem:
[url]aimeos.org/fileadmin/download/aimeos_16.4.3-pre1.zip[/url]

Can you confirm that it works for you too?
#2790 by aimeos
13 May 2016, 16:00
Please remove every configuration you've made for login.
With default settings, everything works as expected in our test environment.
#2794 by aimeos
17 May 2016, 08:04
thomas27 wrote:Can I change the usergroup dependend from the product?


Do you mean to assign a user group upon account creation depending on the product the customer has bought?
This is something you would have to implement yourself by changing the checkout step.