Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#2936 by ivofrie
03 Jul 2016, 16:34
Hi guys!

I have allmost finished my first webshop with Aimeos, really great work guys! It will for shure not be my last implementation into TYPO3.

During the order process, a new backend user is created and the address data is stored in the correct fields, as far as good. But how could the respective user group be set into that user account?

I have allready tried to set "TCAdefaults.fe_users.usergroup = 7" into the the config section of the SysFolder where the users are stored (and yes, 7 is the correct ID of the usergroup).

Thank you for a hint!

Kind regards, Ivo
#2938 by aimeos
03 Jul 2016, 19:18
ivofrie wrote:I have allmost finished my first webshop with Aimeos, really great work guys! It will for shure not be my last implementation into TYPO3.


Great to hear that! :-)

ivofrie wrote:During the order process, a new backend user is created and the address data is stored in the correct fields, as far as good. But how could the respective user group be set into that user account?


Use this configuration:
Code: Select alltx_plugin.aimeos.settings.client.html.checkout.standard.order.account.standard.groupids

It accepts a single group ID or a list of group IDs (an array).
#2941 by ivofrie
04 Jul 2016, 18:39
Dear Administrator,

Thank you so much for your fast answer, even on a Sunday :o

The snipped works, but should of course be modified like that:

Code: Select allplugin.tx_aimeos.settings.client.html.checkout.standard.order.account.standard.groupids = X


Thank you once again, really great that support!
#4145 by ltwmaster
20 Apr 2017, 18:33
Hey Guys,

I have also added the TS to the "Resources" Tab in the Folder "Users", but it doenst work.
Am I getting something wrong? Should the TS be added to the Scheduler Task that sends out the account email? or to the checkout page?

I am using the standard installation package on a fresh typo3 installation.

Cheers in advance,
ltw
#4200 by aimeos
16 May 2017, 15:09
Can you post a screenshot of your configuration? Seems like you've still entered it into the wrong location.
#4203 by ltwmaster
16 May 2017, 15:38
Hi Aimeos,

Thank you for the quick reply!

Do you mean the TS that is in the template? Or which configuration?

I am using the quick installation...

Cheers,
ltw
Attachments
Bildschirmfoto 2017-05-16 um 17.37.21.png
Bildschirmfoto 2017-05-16 um 17.37.21.png (236.31 KiB) Viewed 622 times
#4208 by aimeos
17 May 2017, 19:24
Seems to be the correct configuration. The value "2" is the ID of the "users" sysfolder?

The new configuration is this but that shouldn't matter because there's a fallback:
Code: Select allplugin.tx_aimeos.settings.client.html.checkout.standard.process.account.standard.groupids = 2