Questions around the TYPO3 integration and plugins as well as Flow and NeosCMS
Forum rules: Always add your TYPO3/Flow, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
#3499 by Metalics
06 Oct 2016, 22:41
Hi all,
I am trying to improve our website with aimeos when i have time.
I am having problem with language menu. Problem only occurs in detail view. In List view it works perfectly and when i want to display the english version of the current catalog, language menu works correctly.
But in detail view, for example im viewing the product:
"http://www.elementel.com/EN/products-services/product-detail/d/13/Seluloz_Nitrat_Membran_Filtre/12/". When i use the language menu to display the Turkish version of the product, it redirects to another product e.g.:
http://www.elementel.com/TR/ueruenler-hizmetler/ueruen-detayi/d/26/Naylon_Membran_Filtre/22/

We are having the probem for a long time. I checked some websites in your showcase using aimeos. For example, http://www.werkhaus.ch/ and http://hamag-maschinenbau.de/. Im not sure if they are aware of, but they have same problem.
#3500 by aimeos
07 Oct 2016, 11:39
How did you set up the language handling?
#3504 by Metalics
07 Oct 2016, 19:16
Hello,
My language menu setup is:

DILSEC = HMENU
DILSEC {
special = language
special.value = 0,1
1 = TMENU
1 {
noBlur = 1
NO {
stdWrap.override = DİLİ DEĞİŞTİR ⟶ (TÜRKÇE) || CHANGE THE LANGUAGE ⟶ (ENGLISH)
doNotLinkIt = 1
stdWrap.typolink.parameter.data = page:uid
stdWrap.typolink.additionalParams = &L=0 || &L=1
stdWrap.typolink.addQueryString = 1
stdWrap.typolink.addQueryString.exclude = L,id,cHash,no_cache
stdWrap.typolink.addQueryString.method = GET
stdWrap.typolink.useCacheHash = 1
stdWrap.typolink.no_cache = 0
stdWrap.typolink.title = Türkçe || English
wrapItemAndSub = <li class="language-select Turkish">|</li> |*| <li class="">|</li> |*| <li class="language-select English">|</li>
}
ACT < .NO
ACT = 1
ACT {
wrapItemAndSub = <li class="language-select Turkish linkaktif">|</li> |*| <li class="">|</li> |*| <li class="language-select English linkaktif">|</li>
}
}
}

But i controlled the TypoScript setup:
config.no_cache = 1 solved the problem
Thank you.
#3505 by aimeos
07 Oct 2016, 20:14
"no_cache=1" is a bad choice because it slows down generating the page very much.
Can you try to set "useCacheHash=0" instead? The chash parameter is a common source of such problems.
#3506 by Metalics
07 Oct 2016, 21:50
I tried "useCacheHash=0". Its not working. Same problem with that solution.
It is interesting, no problem with catalogue translation but only with product translation. :roll:
#3507 by aimeos
08 Oct 2016, 14:35
What RealURL version do you use? We have huge problems with with RealURL 2.x, like empty baskets during the checkout process or the checkout confirm plugin is always called together with the checkout standard one, but both only on the second run.
#3508 by Metalics
08 Oct 2016, 15:10
Typo3 Version: 7.6.11
Aimeos Version: 16.7.2
RealURL Version: 2.1.4
#3509 by aimeos
08 Oct 2016, 15:26
Did you try to order a second time just after the first order was completed?
#3513 by aimeos
11 Oct 2016, 17:39
Put a product into the basket and order that product until you reach the "thank you" page. With RealURL 2.x enabled, we can't add this or another product again to the now empty basket. If we reload the basket, the added product is gone.