Aimeos 2021 requires composer 2

Questions around the TYPO3 integration and plugins
Forum rules
Always add your TYPO3, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
User avatar
loeffe1
Posts: 18
Joined: 21 Feb 2020, 10:33

Aimeos 2021 requires composer 2

Post by loeffe1 » 27 Aug 2021, 08:42

It says in your docs that due to a problem with TYPO3 only composer 1 can be used, however the aimeos composer.json requires composer-runtime-api version 2.1. How does that fit together?

Code: Select all

aimeos/aimeos-typo3 2021.07.x-dev requires composer-runtime-api ^2.1 -> no matching package found.

User avatar
aimeos
Administrator
Posts: 5643
Joined: 01 Jan 1970, 00:00

Re: Aimeos 2021 requires composer 2

Post by aimeos » 27 Aug 2021, 14:27

Since 2021.07, composer 2.1+ is required and the documentation has been updated:
https://github.com/aimeos/aimeos-typo3#composer
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply