Istall Aimeos with Laravel 10 Problem

Help for integrating the Laravel package
Forum rules
Always add your Laravel, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
Spam and unrelated posts will be removed immediately!
User avatar
WouterLeybaert
Posts: 1
Joined: 12 Mar 2023, 14:52

Istall Aimeos with Laravel 10 Problem

Post by WouterLeybaert » 12 Mar 2023, 14:59

Error;

Problem 1
- aimeos/aimeos-laravel 2022.10.6 requires aimeos/aimeos-core 2022.10.* -> satisfiable by aimeos/aimeos-core[2022.10.1, ..., 2022.10.12].
- aimeos/aimeos-laravel[2022.10.1, ..., 2022.10.5] require laravel/framework ^9.0 -> found laravel/framework[v9.0.0, ..., v9.52.4] but it conflicts with your root composer.json require (^10.0).
- aimeos/aimeos-core[2022.10.1, ..., 2022.10.12] require ext-intl * -> it is missing from your system. Install or enable PHP's intl extension.
- Root composer.json requires aimeos/aimeos-laravel ~2022.10 -> satisfiable by aimeos/aimeos-laravel[2022.10.1, ..., 2022.10.6].

my versions;
- PHP 8.2.3
- composer 2.5.1
- Laravel 10.3.3

Any solutions that don't resort me to downgrade a version of Laravel?

User avatar
aimeos
Administrator
Posts: 8057
Joined: 01 Jan 1970, 00:00

Re: Istall Aimeos with Laravel 10 Problem

Post by aimeos » 12 Mar 2023, 15:06

Laravel 10 is only supported by the dev-master version at the moment and will be officially supported in four weeks with the 2023.04 release.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

Post Reply