Locale item for site "test-site" not found on fresh aimeos install

Help for integrating the Laravel package
Forum rules
Always add your Laravel, Aimeos and PHP version as well as your environment (Linux/Mac/Win)
Spam and unrelated posts will be removed immediately!
lockhart97
Posts: 21
Joined: 17 Aug 2023, 00:16

Locale item for site "test-site" not found on fresh aimeos install

Post by lockhart97 » 20 May 2024, 12:15

Laravel: 11.0
Aimeos: 2024.04
PHP: 8.2
Environment: Linux

I am stuck in very peculiar problem. I was developing with aimeos and everything was working perfectly. Then there was need to work on different feature and since I use worktrees for my project, I created a new worktree for my new feature. I had to roll back to fresh laravel installation as I wanted to check something. After that I did a fresh install of aimeos in the temp worktree, but running command

Code: Select all

php artisan aimeos:setup test-site
returns error. I tried this commad with fresh DB as well.
Error:

Code: Select all

  Locale item for site "test-site" not found

  at vendor/aimeos/aimeos-core/src/MShop/Locale/Manager/Standard.php:637
    633▕                        return $this->createItemBase( ['locale.siteid' => $siteId], $siteItem, $sites );
    634▕                }
    635▕
    636▕                $msg = $this->context()->translate( 'mshop', 'Locale item for site "%1$s" not found' );
  ➜ 637▕                throw new \Aimeos\MShop\Locale\Exception( sprintf( $msg, $site ) );
    638▕        }
    639▕
    640▕
    641▕        /**

      +24 vendor frames

  25  artisan:13
      Illuminate\Foundation\Application::handleCommand(Object(Symfony\Component\Console\Input\ArgvInput))

But, my previous installation of aimeos in another working is working fine. I have even replaced the composer.json in my temp-wroktree, but still same error. I tried to dig but could not find a solution. Can you please look into it? Let me know if you need more information.

User avatar
aimeos
Administrator
Posts: 8004
Joined: 01 Jan 1970, 00:00

Re: Locale item for site "test-site" not found on fresh aimeos install

Post by aimeos » 22 May 2024, 13:02

We can confirm the problem and are working on a solution.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

User avatar
aimeos
Administrator
Posts: 8004
Joined: 01 Jan 1970, 00:00

Re: Locale item for site "test-site" not found on fresh aimeos install

Post by aimeos » 23 May 2024, 07:35

Problem has been fixed in latest aimeos/aimeos-core package. Please run "composer up" to get the latest version.
Professional support and custom implementation are available at Aimeos.com
If you like Aimeos, Image give us a star

lockhart97
Posts: 21
Joined: 17 Aug 2023, 00:16

Re: Locale item for site "test-site" not found on fresh aimeos install

Post by lockhart97 » 25 May 2024, 10:36

aimeos wrote: 23 May 2024, 07:35 Problem has been fixed in latest aimeos/aimeos-core package. Please run "composer up" to get the latest version.
THanks I will check in my setup and will let you know.

Post Reply